Nexus FCoE Design and Configuration

Nexus FCoE Design and Configuration

I have been deploying more and more FCoE solutions on Nexus 5500s lately and thought it best to write down my design/config here for reference the next time I perform a deployment. What always throws me is that the vPC is intelligent enough to keep the FCoE VLANs isolated per FC storage best-practices (i.e. VLAN 11 on Fabric A, VLAN 12 on Fabric B), but allows the Data VLAN (i.e. VLAN 50) across the LACP port-channel. It’s really a simple configuration to accomplish this, it’s wrapping your head around it that takes the time.

Physical Architecture

FCoE VLAN Architecture

Data VLAN Architecture

Configuration

N5K-A:
vlan 11
fcoe vsan 11
name FCOE_VSAN11
!
interface port-channel3
switchport mode trunk
vpc 3
switchport trunk allowed vlan 50,11
!
interface Ethernet1/7
description File Server
switchport mode trunk
switchport trunk allowed vlan 50,11
spanning-tree port type edge trunk
channel-group 3 mode active
!
interface vfc1
bind interface port-channel3
no shutdown
!
vsan database
vsan 11 interface vfc1
!

N5K-B:
vlan 12
fcoe vsan 12
name FCOE_VSAN12
!
interface port-channel3
switchport mode trunk
vpc 3
switchport trunk allowed vlan 50,12
!
interface Ethernet1/7
description File Server
switchport mode trunk
switchport trunk allowed vlan 50,12
spanning-tree port type edge trunk
channel-group 3 mode active
!
interface vfc1
bind interface port-channel3
no shutdown
!
vsan database
vsan 12 interface vfc1
!